Skip to main content

How to run multiple SAS code in batch?

Issue:

I have multiple SAS code file which I have to run sequentially. How to do that?

Solution:

Create a shell script file to invoke the sasbatch.sh.

myprogram.sh:

#!/bin/bash

nohup /opt/sas/config/Lev1/SASApp/BatchServer/sasbatch.sh /home/sas/$1 -xcmd -nodms -log /home/sas/logs/$1.log -print /home/sas/listing/$1.lst &

In above command you need to change the path depending on your environment. For example: in your organization the sasbatch.sh file may be in different location. 

Create SAS file to call your SAS program:

myprogram.sas:

filename src '/sas//programs';
filename src1 '/home/sas/';

%include src(autoexec.sas);
%include src1(first.sas);
%include src1(second.sas);
%include src1(third.sas);

In the above code, I have pointed filename statement to where my autoexec.sas and SAS programs are located. I have mentioned src as /sas/programs, it is the location where my autoexec.sas file present. I have mentioned src1 as /home/sas, it is the location where my three SAS files first.sas, second.sas and third.sas is present. 

Now after this two files are created place them in same directory. Consider the directory we placed the two code is /tmp, in terminal (Putty) write following command.

cd /tmp
./myprogram.sh myprogram.sas

You will get a message saying nohup: appending output to `nohup.out'

Comments

Popular posts from this blog

Starting Gemfire in SAS

Gemfire is available in both Compute and Mid. The default port is 41415. If you have many gemfire, you may have port numbers incremented by 1, for example: 41416. Gemfire is located under Web. <SASCONFIG>/Web/gemfire. To Start: <SASCONFIG>/Web/gemfire/instances/ins_41415/gemfire-locator.sh start To check Status: <SASCONFIG>/Web/gemfire/instances/ins_41415/gemfire-locator.sh status To stop: <SASCONFIG>/Web/gemfire/instances/ins_41415/gemfire-locator.sh stop If it doesn;t start check port number is occupied by any other process. lsof -i tcp:41415 If you only have one instance then 41415 will be default. If you have Lev2 then it will be 41416

SAS 9.4 server startup order

In Linux / Unix OS we normally use sas.servers to start the services. The script in the background follows an order to start the services. It is important to follow the order to run the services correctly. In this post we can see what is the order to start / stop and to generate the sas.servers script. It is not really required to memorize the order because SAS provide an utility to create the sas.servers script automatically which will start / stop the service in order. Starting order SAS Metadata server Olap server SAS object spawner SAS / SHARE server SAS / connect spawner SAP table server SAP remote services SAS deployment tester server Stopping will be the same in reverse. How to create sas.server script? We can create sas.server script by using generate_boot_script.sh. if you have made any changes to your environment like adding a new server or spawner we can use the script to generate new sas.server. You can use the script even if you have removed the spanner o...

SAS - CLI error trying to establish connection

Issue: User asked me to make a database connectivity to SQL Server. They provided following details SQL server hostname and ip address Database/DSN name Username Password I made entry in ODBC.ini file. You know, SQL Server entries were made in ODBC.ini and Oracle entries were made in TNS.ora file. Everything went fine, took back up of odbc.ini, made entry and saved the file. So to test this connection I ran the libname statement in SAS Enterprise Guide 6.1. It throwed following error. Error Message: My DB team showed that they are able to login   14 GOPTIONS ACCESSIBLE; 15 LIBNAME test ODBC DATASRC=SGE_DS SCHEMA=VST USER=sales PASSWORD=XXXXXXXXX; ERROR: CLI error trying to establish connection: [SAS/ACCESS to SQL Server][ODBC SQL Server Legacy Driver][SQL Server]Login failed for user 'sales'. Solution: First I suspected that Login failed for user 'sales' meant the password provided by DB team was wrong. They responded that they were able to login wi...